Maya动画制作之 acm.pku 1008 玛雅历
凌雪 2018-08-22 来源 :网络 阅读 1404 评论 0

摘要:本文将带你了解Maya动画制作之 acm.pku 1008 玛雅历,希望本文对大家学Maya有所帮助

本文将带你了解Maya动画制作之 acm.pku 1008 玛雅历,希望本文对大家学Maya有所帮助


 题目:Maya   Calendar
   
    Time Limit:
     1000MS
   
    Memory Limit:
     10000K
    Total Submissions:
     33760
   
    Accepted:
     10300
   
    Description
    During
    his last sabbatical, professor M. A. Ya made a surprising discovery
    about the old Maya calendar. From an old knotted message, professor
    discovered that the Maya civilization used a 365 day long year,   called
    Haab, which had 19 months. Each of the first 18 months was 20 days
    long, and the names of the months were pop, no, zip, zotz, tzec, xul,
    yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab,   cumhu.
    Instead of having names, the days of the months were denoted by   numbers
    starting from 0 to 19. The last month of Haab was called uayet and   had
    5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this
    month was unlucky, the court of justice was not in session, the trade
    stopped, people did not even sweep the floor.
    For religious purposes, the Maya used another calendar in which the
    year was called Tzolkin (holly year). The year was divided into
    thirteen periods, each 20 days long. Each day was denoted by a pair
    consisting of a number and the name of the day. They used 20 names:
    imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen,
    eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both
    in cycles.
    Notice that each day has an unambiguous description. For example,
    at the beginning of the year the days were described as follows:
    1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat,
    9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban,   5
    eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10
    akbal . . .
   
    Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : ,
    where the number 0 was the beginning of the world. Thus, the first   day
    was:
    Haab: 0. pop 0
   
    Tzolkin: 1 imix 0
   
    Help professor M. A. Ya and write a program for him to convert the dates   from the Haab calendar to the Tzolkin calendar.
   
    Input
    The date in Haab is given in the following format:
   
    NumberOfTheDay. Month Year
   
    The first line of the input file contains the number of the input
    dates in the file. The next n lines contain n dates in the Haab
    calendar format, each in separate line. The year is smaller then 5000.  
    Output
    The date in Tzolkin should be in the following format:
   
    Number NameOfTheDay Year
   
    The first line of the output file contains the number of the output
    dates. In the next n lines, there are dates in the Tzolkin calendar
    format, in the order corresponding to the input dates.
    Sample Input
    3
    10. zac 0
    0. pop 0
    10. zac 1995
    Sample Output
    3
    3 chuen 0
    1 imix 0
    9 cimi 2801
    Source
    Central Europe 1995
   
   
   
    编程环境: GCC
    解法:[cpp] view plain copy   print?#include <stdio.h>  #include <conio.h>  #include <stdlib.h>  #include <string.h>  int main(){      char Haab[19][7]={"pop", "no", "zip", "zotz", "tzec", "xul", "yoxkin","mol","chen","yax","zac","ceh","mac","kankin","muan","pax","koyab","cumhu","uayet"};      char Tzolkin[20][10]={"imix","ik","akbal","kan","chicchan","cimi","manik","lamat","muluk","ok","chuen","eb","ben","ix","mem","cib","caban","eznab","canac","ahau"};      char temp[7];      int m, *days, d, y, day;      int total,times;      int t,i;            scanf("%d",&total);            days= calloc(total,sizeof(int));      for(times=0;times<total;times++){          day=0;          scanf("%d.%s%d",&d,temp,&y);          for(m=0;strcmp(Haab[m],temp) && m<19 ;m++);          day+=1+d+m*20+y*365;          days[times]=day;      }      printf("%d/n",total);      for(times=0;times<total;times++){          day=days[times];          y=(day-1)/260;          day-=y*260;          d=day%13; if(d==0) d=13;          m=day%20; if(m==0) m=20;          printf("%d %s %d/n",d,Tzolkin[m-1],y);      }             getch();      return 0;  }  #include   <stdio.h>
    #include <conio.h>
    #include <stdlib.h>
    #include <string.h>
    int main(){
     char Haab[19][7]={"pop", "no", "zip",   "zotz", "tzec", "xul",   "yoxkin","mol","chen","yax","zac","ceh","mac","kankin","muan","pax","koyab","cumhu","uayet"};
     char Tzolkin[20][10]={"imix","ik","akbal","kan","chicchan","cimi","manik","lamat","muluk","ok","chuen","eb","ben","ix","mem","cib","caban","eznab","canac","ahau"};
     char temp[7];
     int m, *days, d, y, day;
     int total,times;
     int t,i;
     
     scanf("%d",&total);
     
     days= calloc(total,sizeof(int));
     for(times=0;times<total;times++){
     day=0;
     scanf("%d.%s%d",&d,temp,&y);
     for(m=0;strcmp(Haab[m],temp) && m<19 ;m++);
     day+=1+d+m*20+y*365;
     days[times]=day;
     }
     printf("%d/n",total);
     for(times=0;times<total;times++){
     day=days[times];
     y=(day-1)/260;
     day-=y*260;
     d=day%13; if(d==0) d=13;
     m=day%20; if(m==0) m=20;
     printf("%d %s %d/n",d,Tzolkin[m-1],y);
     }
     getch();
     return 0;
    }
   
    这是一道比较平常的日期转化题目,经查证,那两个历法:Haab 和Tzolkin   都是实际存在的,这也让我更多了解了点历史,很不错的一道题目。
    开始想过用 enum 做,但个人对于enum 掌握的并不是很好,试验了下原来它仅仅是一个 (个人理解) 让程序员更方便记住数字的代表,并不能提供 数字   到 文字 的转化。 如果需要转化,上一些论坛搜索,人们提供的是这个解答方案:加上一段比如 switch 代码。
   
    其中有一处很容易出现思维漏洞,就是最后那一处,要考虑Tzolkin最后一天的问题。感谢pku 里面discussion   某牛人提供了测试数据,让我及时发现了问题 。(测试数据:4. uayet 259 ,应该输出 年份最后一位是4, 不是5.)    

本文由职坐标整理并发布,希望对同学们有所帮助。了解更多详情请关注职坐标常用软件之Maya频道!

本文由 @凌雪 发布于职坐标。未经许可,禁止转载。
喜欢 | 0 不喜欢 | 0
看完这篇文章有何感觉?已经有0人表态,0%的人喜欢 快给朋友分享吧~
评论(0)
后参与评论

您输入的评论内容中包含违禁敏感词

我知道了

助您圆梦职场 匹配合适岗位
验证码手机号,获得海同独家IT培训资料
选择就业方向:
人工智能物联网
大数据开发/分析
人工智能Python
Java全栈开发
WEB前端+H5

请输入正确的手机号码

请输入正确的验证码

获取验证码

您今天的短信下发次数太多了,明天再试试吧!

提交

我们会在第一时间安排职业规划师联系您!

您也可以联系我们的职业规划师咨询:

小职老师的微信号:z_zhizuobiao
小职老师的微信号:z_zhizuobiao

版权所有 职坐标-一站式IT培训就业服务领导者 沪ICP备13042190号-4
上海海同信息科技有限公司 Copyright ©2015 www.zhizuobiao.com,All Rights Reserved.
 沪公网安备 31011502005948号    

©2015 www.zhizuobiao.com All Rights Reserved

208小时内训课程